Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2025 - 09:00 CDT
Scheduled
Coinbase will undergo maintenance on Saturday, Oct 25 from 10 AM–2 PM ET. During this time, CryptoIRA trading will be unavailable. Please close any open orders you don’t want to execute when service resumes.
Posted Oct 22, 2025 - 12:17 CDT
This scheduled maintenance affected: Web app (app.altoira.com) and CryptoIRA mobile app.